The Eggplant Network Scenario Builder

The Scenario Builder allows you to create a chronological network experience by combining two or more emulations and scenarios (elements) together to run over time. A more realistic network experience can be provided by joining together each element using a transition. Transitions define what happens when changing between elements, i.e., switching from a 2G network to a 3G network.

Scenario Quick Guide in Eggplant Network

The Scenario Quick Guide window appears the first time you work in Scenario Builder.

The Scenario Builder page is divided into two sections:

  • Workspace, at the top of the page, where you add emulations, scenarios, and transitions for use in your scenario. You then drag the elements from the workspace to the timeline to build the scenario.
  • Timeline, at the bottom of the page, graphically displays the scenario with each element and the ability to make changes. When played, the timeline vertical bar moves from left to right to indicate the current position of the scenario.

Scenario Builder GUI in Eggplant Network

General Usage

The following provides a general overview of the main items on the Scenario Builder page.

Buttons

Clear All: Removes everything that you’ve added from the workspace.

Clear Timeline: Removes everything from the workspace and timeline.

Important: Be cautious about using either of the Clear buttons, unless you want to start the design of the Scenario from scratch.

File Menu

New: Enter a name and description for the scenario. From here on, any actions taken on this page are automatically saved in the background.

Note: Leaving Clear Workspace selected removes everything from the workspace.

Load: Load an existing scenario from the Home page or by selecting File > Load from the Scenario Builder.

Rename: Provide a new name for an existing scenario.

Save As: Save the current scenario configuration under a new name.

View Menu

Background: Change the background canvas.

Arrange Workspace: Automatically group elements neatly on the Workspace.

Quick Guide: Display the Scenario Builder Quick Guide.

Auto save

The Scenario Builder includes an auto save option, which means that all changes are automatically saved in the background.

Workspace

The Workspace is where you add emulations, scenarios, and transitions (elements) for use in your scenario. When you add an emulation or scenario to the Workspace, a copy is created and no link is maintained to the original. Transitions are built in; their behavior can’t be customized.

Import emulation buttons in Eggplant Network Scenario Builder

To add an emulation or scenario, click either Standard or Scenario. Choose the emulations and scenarios that you want to add to the Workspace, then click Import.

Note: Only scenario files containing emulations and transitions (explained later in this section) can be imported into the Workspace. Scenarios containing other scenarios cannot be imported and are excluded from the list.

The properties of each emulation and scenario can be modified. Click the cog and select from the following options:

Scenario settings in Eggplant Network

Change: Change the element instance to a different emulation or scenario. You are presented with a list of similar emulations to choose from.

Edit: Change impairment field values for this instance. You are directed to the Emulation page, where you can make changes to emulation impairment fields, endpoints, and add more links if needed.

When you have finished making changes to the emulation, click Save — otherwise, the changes are discarded.

Important: To return to the Scenarios page, click Back to Scenario at the top of the page. Do not use the back button in your browser.

Duplicate: Creates a copy of the element that can be added to the timeline.

Colors: Change to affect an element’s visual appearance.

Rename: Provide a different name for an element.

Remove: Delete an element from the workspace.

Change the length of time for an Element

Each element (emulation/scenario/transition) can be altered for the length of time it is to run. Click the element, and thick line appears on its right side.

Hover, click on the line, and drag left to shorten or right to extend the duration of the emulation on the timeline. Each small square on the timeline represents 5 seconds.

Transitions

Click a transition to add it to the Workspace. Each transition has a cog menu to change, edit, duplicate, or remove the transition.

Note that Edit is reserved for future use.

Transition buttons in Eggplant Network Scenario Builder

Available transitions include:

Graduating: This transition changes all emulation parameters gradually between the values of the previous and next elements.  Changes are made every 0.1 seconds.

  • If loss in the element before is 80% and loss in the next element is 20%, then during the transition the loss would be gradually reduced from 80% to 20% every 0.1 seconds.
  • If a gradual change cannot be calculated (e.g., due to a change of algorithm or a link being enabled or disabled), then the change to that parameter is made at the end of the transition time, not gradually.

Variable: This transition changes all emulation parameters in a random manner between the values of the previous and next elements. Changes are made every 0.1 seconds.

  • If loss in the element before is 80% and loss in the next element is 20%, then during the transition the loss would take a different random value between 80% to 20% every 0.1 seconds.
  • If a variable change cannot be calculated (e.g., due to a change of algorithm or a link being enabled or disabled), then the change to that parameter is made at the end of the transition time, not variably.

Outage: This transition creates an outage as follows:  In the first quarter of the transition, the loss is gradually increased to 100% from the value in the previous element.  In the middle half, there is 100% loss.  In the last quarter, the loss is changed gradually from 100% to the value in the next element. Changes are made every 0.1 seconds.

  • If loss in the previous element is 80%, the loss in the next element is 20%, and the transition is 20 seconds long, then during the transition the loss would begin by going from 80% to 100% changing every 0.1 second for the first 5 seconds. Loss would then remain at 100% for 10 seconds.  Then loss would change from 100% to 20% in the final 5 seconds in 0.1 second increments.
  • If a variable change cannot be calculated in the first quarter or last quarter of the transition (e.g., due to a change of algorithm or a link being enabled or disabled), then the change to that parameter is made at the end of the transition time, not variably.

Timeline

After you have added all the required elements on to the Workspace, drag them on to the Timeline in the order you would like to play them. Note that you can reorder elements and also change other settings within the timeline.

If you need to change the duration of any element, you can do so using the same method described above.

Once you create or load a Scenario, you can play it back over time. Select Play from the Playback controls. The playback vertical bar progresses along the timeline showing the current position in the Scenario. Once started, the following Playback controls are available:

  • Stop causes Scenario playback to halt. The playback vertical bar returns to the beginning of the Scenario.
  • Pause continues to play the impairments for the current position in the scenario. Network traffic continues to flow through the emulator. Press play to restart the Scenario playing from the current position.
  • Skip Back moves to the start of the current element.
  • Skip Forward moves to the end of the current element.

Stop, Continue, or Repeat the Scenario

Playback and speed options in Eggplant Network Scenario Builder

Three options are provided on the stop button to determine what happens when playback is complete.

  • Stops Emulation: When the Scenario finishes, the playback vertical bar returns to the start of the Scenario.
  • Stays on: Playback remains at the end of the timeline, and the network traffic continues passing through the emulator using the scenario’s current impairment settings.
  • Repeat: Returns to the start and repeats playback continuously until manually stopped.

Playback Speed

The Speed menu allows you to slow down or speed up the playback of a Scenario.

¼ or ½: Slows down playback. For example, if the scenario’s runtime was 60 seconds and 50% was selected, the total runtime would increase to 120 seconds.

2x or 4x: Speeds up playback. For example, if the scenario’s runtime was 100 seconds and 2x was selected, the total runtime would decrease to 50 seconds.

 

This topic was last updated on June 21, 2019, at 02:49:49 PM.

Eggplant icon Eggplantsoftware.com | Documentation Home | User Forums | Support | Copyright © 2020 Eggplant